2

In QGIS 2 I would go the the settings menu and select the snapping options but this option is not there in version 3. I have found the snapping options in digitising options but these don't seem to allow one to turn snapping off and on on a layer by layer basis.

I have done standard searches but can't find anything for GIS 3 there may be stuff there but it must be buried in all the hits for older versions.

The problem I am having is that I can't move vertexes small distances and changing snapping tolerance does not seem to make any difference. This was very confusing when trying to come to grips with the new vertex tool.

Update: I have also found Project->Snapping options which again does not allow control on a layer by layer basis but did allow me to set the snapping radius in meters which helped which has relived the immediate pain but I still need to be able to turn snapping off for this layer.

  • Snapping options was moved under Project menu. – lrssvt Mar 24 '18 at 8:16
4

As Irssvt suggest the snapping options are now under the Project menu and I had found them there.
What was not clear was how one disabled snapping altogether -- the 'off' option had gone from the menu and I failed to recognise the significance of the magnet icon. That is what turns snapping on and off.

0

I thnik you can disable snapping altogether by switching from all layers to advanced configuration in the first scroll window. And i think the magnet is to enable/disable snapping options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.