1

I have a QGIS file with about 10 layers (shape files, web and a joined csv). Every time I close the file and open it, all layers are unlinked and the 'Handle Bad Layers' dialog appears. Needless to say, its tedious to relink every time and this behavior was not there earlier.

I've not changed the location of any of the layers. In fact, I tried moving them all to one location and then relinked them, but after I shut and opened the file again, the behavior did not change and the bad layers dialog came up again.

What could be going wrong? How could I correct this?

QGIS 2.18.16 on Ubuntu 16.04

  • Are they locally stored or on a network? What happens if you save one of these layers in a new project then close and re-open it? – firefly-orange Mar 25 '18 at 22:15
  • The files are local--they are on a NTFS drive that has all my data, but I've never faced permission issues with it. I tried opening a new file and adding a layer that I had previously used in the older file, and the error did not come when I shut and reopened the file. After opening my original file again (the one with the issue), it had now begun to correctly link all the layers again, except one! I am surprised at this behavior though am happy to have my layers linked again without having to lose all the styling work done--there's a chance of it reverting to not linking layers, at this rate. – Swastik Mar 26 '18 at 12:19
  • maybe save the styles as qml files and then remake the project – firefly-orange Mar 26 '18 at 14:31
  • The error is now recurring with every file after a few instances of closing and reopening them. I really need some help here. Shall I file a bug report? – Swastik Mar 29 '18 at 3:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.