4

1) I wanted to let the labels of my 'river' appear in scale 25 Mio.

2) the name of the river shall not get smaller when I zoom-in and zoom-out, the size of the label should stay the same.

I want the labels to appear for 4 rivers, which are in my attribute table named as 'hoe_name'.

Now the name of the river in scale 25 Mio only one is displayed:

enter image description here

In scale 12 500 000 appears only three:

enter image description here.

These are my label settings: 'Show labels for this layer':

enter image description here

How can I get all 4 (labels of my river) to appear at a scale 25 Mio. and with the same size?

  • No problem. It's a good question, just some minor formatting changes. – HeikkiVesanto Mar 26 '18 at 9:59
2

The labels are not shown because they would overlap with other features. You can go to the rendering tab and instruct to show all labels

enter image description here

| improve this answer | |
  • thx, I did these already, it wasn't working at the beginning, but now it's working. is it possible to make only one of the label in 'curved' shape? I used 'parallel', all 4 labels are displayed, but not in curved shape. I tried to use 'curve', all of my labels are disappeared(I've also set the coordinates: x and y, wasn't working thou).could you help? – ndr Mar 26 '18 at 11:27
  • Should be possible displaying only one label as curved and the others as parallel, it's a nice application for data defined override, but you should consider asking this in another question. – Eva Großmann Mar 26 '18 at 11:39
4

Interesting situation. Looking at your second screenshot (1:12500000) and your comment to the answer by @JGH, the root cause now seems to be your Placement setting.

Your river labels are placed using Curved option, and Maximum angle between curved characters option was likely set to 25.0 degrees (default value).

This has prohibited river names except for the most straight one (Kapuas river).

enter image description here

Increasing this angle up to 45.0 degrees allows more rivers to show up, including highly meandering Mahakam river.

enter image description here

Setting appropriate maximum angle is tricky... the choice of label font (your Times Semibold) would also affect the output.

| improve this answer | |
  • oh, thank you so much, now it's working for (Mahakam), rest of them are still not in the great position, I think I have to move them manually? they(rest of the 3 rivers) are not exactly on the line, but the middle of the line (like yours on the second image) it hasn't had the option called "distance" that I could change the distance between line and labels, any suggestion? Thanks for advance! – ndr Mar 27 '18 at 6:04
  • @Nadira Glad it worked (partially, though :). I agree with you that the appearance is not perfect. As the label placement is hard part of cartography, you may as well do it manually when more detailed control is required. – Kazuhito Mar 27 '18 at 6:48
  • Arigato :) I've tried to move them manually, but after moved it appears horizontal no more curved, but I'll try more... hope it works – ndr Mar 27 '18 at 7:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.