I am trying to get PyScripter 3.3 64-bit to run on my desktop computer. I was successful in getting PyScripter 32-bit to run, but I require the 64-bit version.

It seems that it is unable to recognize the Python (3.6.2) engine that was installed with ArcGIS Pro 2.1, when I attempt to launch PyScripter I receive the following error:

Error Message

What steps should I take to get PyScripter to recognize my installed version of Python?

*Note: I also currently have ArcGIS Desktop software installed on my computer with its version of Python (2.7.14).

  • I gave up trying to use pyscripter for scripts that will run in Pro. Go to the package install in the options and install another IDE called spyder. When that is installed it works with python 3 and the version of arcpy for pro. I can just run it about another colleague has to go to the python command line window in the ArcGIS group on windows and run it from there, not sure why...
    – Hornbydd
    Mar 27, 2018 at 22:17
  • +1 for spyder. And for a full featured IDE that works with Desktop and Pro (and conda and virtualenv) python, I recommend PyCharm, though it has a bit of a learning curve.
    – user2856
    Apr 1, 2018 at 11:59

3 Answers 3


I did a lot of research and determined that Pyscripter does not work well with virtual environments; therefore it does not work well with ArcGIS Pro 2.1; and I was unable to get them to connect.

I attempted to install Sypder from the Python Packages provided with ArcGIS Pro 2.1, but unfortunately I could not get them to work either; as the install kept failing. I contacted Esri regarding this issue and they stated that 'this problem can occur when the Python Package Manager doesn't have permissions to folders, or network access to reach the modules stored in Conda'. Then they suggested that I run conda install -c anaconda spyder in the Python Command Prompt, and it worked to install the package as long as I was running the Python Command Prompt as an Administrator. This successfully installed the Spyder package.

So I installed PyCharm Community Edition (https://www.jetbrains.com/pycharm/download/#section=windows); and everything seems to work properly now. For the setup I followed the steps in the initial post at the following link (https://community.esri.com/docs/DOC-8359) and I am now able to work with the correct version of python.


I have ArcGIS Pro 2.3.1 installed along with Pyscripter 3.4.2 64bit. Running Anaconda Python 3.6.6 64bit (managed by ArcPro)

stock Python location, read-only C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3

From the Pro Python Package Manager, I've Cloned and Activated Python to a new env. C:\Users\yourname\AppData\Local\ESRI\conda\envs\arcgispro-py3-clone

the ever important ArcGIS PTH file is present, arcgispro-py3-clone\Lib\site-packages\ArcGISPro.pth

to add the venv to Pyscripter, Run, Python version, Setup Python, +, path to the conda env folder (arcgispro-py3-clone in my case)

enter image description here


PyScripter, at least recent versions, work fine with ArcGIS Pro and conda environments. See the blog post on Using PyScripter with ArcGIS Pro for details.

If there are folder permission issues mentioned above you can run PyScripter as an Administrator.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.