2

I have set up the new QGIS Web Client 2 (QWC2) (https://github.com/qgis/qwc2-demo-app) including the demo app and got it running quite easily.

I have created a QGIS Server WMS and also can include it in other QGIS Projects as WMS. So the WMS itself is working. The project's CRS is set to EPSG::25833.

In the qwc2-demo-app-master -> themesConfig.json I have replaced the first theme with my own WMS and specified the EPSG according to my project (EPSG::25833).

themesConfig.json

I "yarn start" the WebClient and it shows "webpack: Comlied successfully". The WebClient shows up on localhost:8081 and also my own project shows up, since it is set to default. It is also displayed in themes and legends, the features however are NOT displayed on the map.

enter image description here enter image description here

I'm stuck at this point and tried to change the QGIS Server CRS to EPSG::4326... but my features never show up on the map.

I cannot find much about this relatively new WebClient development.

I reproduced the exact same procedure on another machine and it works. However, as soon as I add another Layer to my QGIS Project (the serving WMS layer) is is not showing any feature any more at all... clueless!

enter image description here

  • Could it be layer ordering? – nmtoken Mar 28 '18 at 18:04
  • I thought about that aswell but could not find any configurations regarding layer order. – adryanh Mar 29 '18 at 6:22
  • @adryanh Did you ever solve this? I'm experiencing the same thing and, like you, feel a bit stuck :/ – Niklas Jun 29 '18 at 13:46
  • Sorry, I was never able to solve this problem since I had other tasks to take care of. Now I am back at it and will try to find a solution. Any advice is helpful! I will share if I made progress! – adryanh Jul 5 '18 at 9:36
  • Did you ever solved this? I have same problem. – Xpym482 Feb 19 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.