I want to resample rasters of e.g. 2 m resolution to the same raster cell size and projection of an existing raster (25 m). However I cannot really find answers how to do it properly. I managed to resample the input raster to 25 m, but this means the new raster grid has its own grid projection/orientation, thus not matching the 25 m raster grid of the masking raster.

  • 1
    Have you tried "Allign Rasters..." in the Raster menu? – RJJoling Mar 31 '18 at 9:17

Following comment by @RJJoling, this is QGIS Align Rasters tool workflow:

enter image description here

  1. Click on a green + icon.
  2. Input raster layer is the raster you want to change (in your case: originally 2m resolution). Give an Output raster filename. Various Resampling method are available... , Bilinear or Cubic would be good enough to upscale (coarsen) the grid size.
  3. Raster layers to align: lists the raster you want to change (from 1.)
  4. Reference layer is the base layer. In your case the existing 25m resolution raster.

  5. Clip to extent option is also important in many cases (especially when you need to perform raster-raster calculations).

| improve this answer | |
  • Thank you for this detailed description! I used align raster before but for some reasons the new 25m grid did not match the reference 25 m grid. Now with your description it does :-) (I don't know exactly why, but it is working). – karoorobin Apr 2 '18 at 8:07

You can use the GDAL Tools plug-in. After turning on the plug-in in the Raster menu you can find Conversion/Translate. It is a front-end for gdal_translate which can change resolution too. You can set outsize in percents, you should set 1250% for the outsize.

Alternatively the gdal_translate command line version can be used, where the output resolution can be set using -tr switch.

Another alternative can be found in the processing toolbox (e.g. in SAGA or GRASS group)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.