1

I have been trying to use the mosaic tool in ArcMAP to merge several GeoTIFFs together, using BLEND as Mosaic Operator and LAST as Mosaic Colormap Mode. I placed all files that I want to merge in the same folder, and also copied the first one as a target file.

enter image description here

That way, I had 8 folders that needed to be mosaiced. For the first two I had little issues, but with all other the program kept giving me an error message.

I tried various things, nothing worked.

How can I resolve this error?

enter image description here

  • Do all the rasters has the same (number of bands and pixel depth)? please check this link – Moh Apr 5 '18 at 14:32
  • 1
    Yes, they all have the same number of bands and pixel depth. However, thank you for the link. I never used the "mosaic to new raster" - tool, only the "mosaic" - tool. I don't know what the difference is... – Djro33 Apr 5 '18 at 14:46
1

I think the issue is with the dash (-) in the target file name before the Copy.tif in ####_#### - Copy.tif. You need to change that to underscore (_).

Also as commented by User2009, you have another tool that enables you to mosaic to a new raster instead of an existing raster. However, you need to make sure that the pixel depth of the output mosaic raster data is similar to the input raster data.

  • That was also something I thought initially, so I changed it. But it didn't work. And for the two folders where it did work, they also had a file with a "- Copy" in its name. But I will try out the other tool and see if it changes anything. – Djro33 Apr 6 '18 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.