0

I am looking to convert a CityGML file into a shapefile to perform some spatial analysis on it. I am completely new to the CityGML format and keep running into issues when trying to import them in either ArcMap or QGIS.

In QGIS (Version 2.18.2): I have tried to import the .gml via 'add vector layer'. The validity check states 'unknown geometry type 0'.

In ArcMap (Version 10.3.1): I tried both data interoperability tools > quick import and interoperability connections > add interoperability connection. I still end up with No Geometry.

Is there something wrong with the structure of the CityGML?

  • Maybe you should try importing a sample CityGML. citygml.org/samplefiles This way you can check if the problem is in the importing process, or with the particular file you're using. – csk Apr 5 '18 at 19:41
  • Did you define the coordinate system when you import? – Moh Apr 5 '18 at 20:19
  • I just tried it again with the Delft sample file (3d.bk.tudelft.nl/opendata/3dfier) but I still seem to be doing something wrong. I defined the coordinate system as specified in the .gml (EPSG:7415) and tried again to use the ArcMap 'quick import' in data interoperability. I again get an error this time stating 'xml parser error: 'error at file: "line-0: column:0 message:unable to open primary document entity: 'N:\delft.gml\cityGML_02\CityGML.xsd". I'm pretty clueless. Thanks for your help! – emily Apr 5 '18 at 21:07
  • What N: drive refer to? because this error normally refer that (You don't have the right permission to read the file) – Moh Apr 5 '18 at 21:38
  • the drive shouldn't be a problem! It seems to me like I'm missing something in the import settings. – emily Apr 6 '18 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.