2

I’d like to use qgis2web to display a photo when you click on a polygon in the map using qgis2web, but I can’t seem to find the correct settings.

I have a table with a column named photos. Each row has a field with a html link to an image. I’ve read that in version 2.8 you would simply choose “photo” in the field edit widget, but there is not a photo option in QGIS 3. The replacement method appears to be the “Attachment” option in the Attributes Form in the Layer Properties.

I have tried every combination I can think of and still can’t get it to work. The closest I have come is an html link that when clicked on, would open another window to display the image.

Using QGIS version 3.0.1-Girona and the latest plugin update for qgis2web

Can anyone let me in on the secret to making this work?

closed as off-topic by PolyGeo Aug 13 at 10:29

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

2

Well I’m embarrassed to say that my problem was a typo that I copied from test to test to test. Qgis2Web recognizes an url and works flawlessly without any setting at all. Assuming you don’t have a typo….

Not the answer you're looking for? Browse other questions tagged or ask your own question.