3

Now that I have QGIS 3 running nicely on my Mac. I am having another go at building some plugins. I have installed the plugin builder plugin and run it without problems and it has generated a source directory.

I cd into the generated source directory and type make. First time it failed to find PyQt5, so I install that with pip3 install pyqt5-macos-built and try again. This time I get:

macMini:gpsconnect rful011$ make
pyrcc5 -o resources.py  resources.qrc
/usr/local/bin/python3.6: No module named PyQt5.pyrcc_main
make: *** [resources.py] Error 1

The resource file contains:

macMini:gpsconnect rful011$ cat resources.qrc 
<RCC>
    <qresource prefix="/plugins/gps_connect" >
        <file>icon.png</file>
    </qresource>
</RCC>

Is this what one would expect? I can't figure out if the plugin builder is not working properly or wether the problem in in my PyQT install.

1
  • 2
    It may be useful to try python3 -m pip install PyQt5 to install PyQt5. Commented Apr 11, 2018 at 16:16

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.