0

I have a number of .gpx files that I want to convert so that they can be viewed in ArcGIS. When I have tried using the ArcToolbox 'convert from GPS' tool, it has previously worked. Recently however, when I go through the process of converting the files from .gpx to .shp, no file is generated. The results log says that the Output Feature class is empty, but there is definitely data there, which can be viewed when you use a gpx viewer such as explorer. I have never had this problem before and don't know why ARC thinks the files are empty.

Any suggestions on why it's doing this and if there is another way that I can convert .gpx to .shp?

1

I think if you want to get to the bottom of why ArcMap is not working with your GPX data you need to be providing us with the data, as currently your question is as similar as saying "my car has stopped working do you know why?"

As for converting GPX there are other applications that can do this; I find QGIS good for this type of problem or if you don't want to install a full blown GIS system you could consider using GPSUtility or better still actually search GIS SE and find entire threads like this one !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.