-1

I tried to delete all rows where Field "Width" has value 2?

closed as unclear what you're asking by Spacedman, aldo_tapia, whyzar, xunilk, Hornbydd Apr 11 '18 at 16:06

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    You tried and then what happened? – Spacedman Apr 11 '18 at 13:54
  • i tried the same what @Erik Lohman suggested and it works – AED EDA Apr 17 '18 at 9:06
2

I don't know, whether you directly can delete rows via the calculator (doubt so strongly), but you can use select by expression, type "width" = 2 and then delete the marked rows manually.

3

You should be able to follow these steps to delete the rows with the value of interest, in your case 2.

  1. You will need to make the layer editable

enter image description here

  1. Open the attribute table and select the features of interest
  2. Then click the delete button.

enter image description here

Not sure if you could use the field directly to delete.

Not the answer you're looking for? Browse other questions tagged or ask your own question.