Again having issues with building QGIS 3 on Manjaro Linux, from AUR. After solving my previous problem (QGIS 3.0 can't load plugin processing, no module named 'osgeo', on Manjaro Linux), I now get the following error message:

Couldn't load PyQGIS.
Python support will be disabled.

Traceback (most recent call last):
  File "", line 1, in 
  File "/usr/share/qgis/python/qgis/__init__.py", line 72, in 
    from qgis.core import QgsFeature, QgsGeometry
  File "/usr/share/qgis/python/qgis/core/__init__.py", line 34, in 
    from qgis._core import *
RuntimeError: the sip module implements API v11.0 to v11.3 but the within renderer)

.. versionadded:: 2.6 module requires API v12.4

Python version:
3.6.4 (default, Jan  5 2018, 02:35:40) 
[GCC 7.2.1 20171224]

QGIS version:
3.0.1-Girona 'Girona', exported

Python path:
['/usr/share/qgis/python', '/home/thiago/.local/share/QGIS/QGIS3/profiles/default/python', '/home/thiago/.local/share/QGIS/QGIS3/profiles/default/python/plugins', '/usr/share/qgis/python/plugins', '/home/thiago/anaconda3/lib/python3.6/site-packages', '/usr/lib/python36.zip', '/usr/lib/python3.6', '/usr/lib/python3.6/lib-dynload', '/usr/lib/python3.6/site-packages']

I have recompiled gdal, python-gdal, have used pip to install the latest version of sip, but I still get the same error, after several rebuilds. This error means QGIS starts without python support, making it pretty much useless for any analysis.

  • If you have a newer version of sip than your QGIS package is compiled against, you have to recompile QGIS as well. – AndreJ Nov 26 '18 at 10:38

Since posting this question, I switched to Ubuntu 18.04 to make it work. But for people having the same problem, there is now an experimental Flatpak version of QGIS that might minimize these dependency problems:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.