1

I have a simple line added as a layer from a KML file. I can select the features and show numerous nodes. It is in edit mode. Normally I would expect to be able to delete a node, split a line, etc. but none of the advanced digitizing works. The vertex tool is grayed out. I get the error "CAD tools are not enabled for the current map tool". I have scoured Google and am at a loss.

1

Not probably the correct way to do things but I selected Vector/Geometry Tools/Simplify/Run in Background. This created a new layer titled "added geom info" which I was then able to edit with the Vertex tools. Hopefully someone can answer why I needed to go to that additional step as it is not intuitive. The KML file was created from Google My Maps highlighting a route so it must have to do something with the line being a coordinate or something?

0

I had same problem- Imported a .kmz polygon and it could not be edited. Solution is to go to vector-Geoprocessing-dissolve. As default, a new layer named 'Dissolved' is created. This can be edited. Rename this to your original file and delete the imported file.

0

To enable vertex editing your layer needs to have a column set as Primary Key. This is not possible in some data formats.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.