0

Installed QGIS 3.0 (w/Python 3.6.5) to replace v2.X. Started a new project - imported shapefiles and everything looks good.

Problem: Click "Create New Shapefile Layer" and I get the pulldown menu (file name, geomeotry type, etc.) Fill everything out and click "ok" I get this:

Layer creation failed. Please check message log for further information.

Message log says this:

2018-04-13T09:04:34 Warning:

That's it. Warning is blank. Under the OGR tab I've got:

2018-04-13T09:04:34 WARNING Creation of OGR data source SG sites.shp failed: Failed to create file SG sites.shp: Permission denied.

Why is my permission being denied. Tried a full reinstall but results are the same.

closed as off-topic by Ian Turton Apr 13 '18 at 16:32

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – Ian Turton
If this question can be reworded to fit the rules in the help center, please edit the question.

  • which directory are you trying to write to? do you by some chance not have permission to write there? – Ian Turton Apr 13 '18 at 13:20
  • 1
    Try without whitespace in the name – BERA Apr 13 '18 at 13:25
1

Thanks - problem solved. It was a problem with admin priv. Had another user on this machine yesterday and the permissions had been changed. Switched to 'admin' and now it works as expected.

Cheers!

Not the answer you're looking for? Browse other questions tagged or ask your own question.