1

I tried to import a virtual raster (that's possible right?) into GRASS v. 7.4.0 loaded as a plugin of QGIS v. 2.18.18. It gave me this error however. I know the rasters in the VR are NAD83 (I checked the metadata to be certain), and my location/ mapset is also NAD83 (I double checked this as well), so why is there a projection error? I didn't get this error when I loaded the rasters individually either

g.proj gave me:

C:/PROGRA~1/QGIS2~1.18/apps/grass/GRASS-~1.0/bin/g.proj.exe -p -PROJ_INFO-------------------------------------------------

name : GRS 1980(IUGG, 1980)

ellps : grs80

proj : ll

towgs84 : 0,0,0,0,0,0,0

no_defs : defined

-PROJ_UNITS------------------------------------------------

unit : degree

units : degrees

meters : 1.0

Successfully finished

1

You can (triple) check the projection of the virtual raster with gdalinfo, and the GRASS location setting with g.proj -p

If you're sure they are equivalent, then just use the "Override projection check" option when importing. It appears when you click on the "Show advanced options" button.

2
  • Not sure how to interpret this output it gave me, but I just created this mapset and specifically set it NAD83, so it would be impossible for it to be anything else? I'm going to put the output in the original question so the formatting's better
    – Shane
    Apr 17 '18 at 5:44
  • I don't know what the deal with the error was, but "override projection check" seems to have fixed it
    – Shane
    Apr 17 '18 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.