2

I installed and configured the qgis client ( Version 1 ). It works for the "Hello world" map, but anything else ( e.g. naturalearth ), causes the mapserv fcgi to crash. I tried to figure out what is going on, but I can't figure it out.

I tried installing GWC 2, but couldn't even get pass the yarn command.

I am new to QGIS, so can someone bring me up to speed on the web client i.e. which one to install and how?


I am running qgis 2.18.16 on Ubuntu 16.04 . I pulled the qgis web clinet from Github. As I mentioned it works for the hello world map, but not for anything more complex. When I try, for example with naturalearth_110million.qgs, I see this error in the Apache error log:

[fcgid:error] [pid 28782] mod_fcgid: process /usr/lib/cgi-bin/qgis_mapserv.fcgi(28791) 
exit(communication error). 

Can you tell me how can I run the fcgi from the command line with the appropriate parameters?

closed as too broad by PolyGeo Jun 25 '18 at 19:44

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    It is important to provide more platform information and bugs to help you. What operating system are you using? which version of QGIS are you using? What are the errors you get when installing qwc2? – SamTux Apr 15 '18 at 13:59
  • You could try looking into the apache logs. But if your fcgi fails, you should try running the executable itself, that will show you if your fcgi server is actually able to start. There could be some other completly different problem, so it would help if you told us what you tried and where (OS) like SamTux. – Piskr Apr 15 '18 at 21:03

Browse other questions tagged or ask your own question.