0

I need to merge two shapefiles and the issue is that one shapefile has WGS 84 coordinate system and the second OSGB 1936.

When I try to do the trick with MMQGIS -> Combine -> Merge layers I get an output shapefile but the two layers do not match at all.

3

You need to re-project one of your layer (right click then "save as" then select the coordinate system...) before merging. Choose witch one to re-project depending on your final output (for exemple if you want your merge layer to be on OSGB1936 re-project the shapefile on WGS84 to OSGB1936)

MMQGIS didn't re-project layer, you should do it yourself before merging. in QGIS 3.0 you could use the merge layer tool from the processing panel, this tool do the reprojecting for you and work

  • right..that makes sense...just bear with me :) – aaaaa Apr 16 '18 at 9:29
  • it does not work. both layers with the 2 different coordinates appear correctly in the map when taken independently. but when merged it does not work – aaaaa Apr 16 '18 at 9:35
  • If they appear correctly with 2 different coordinate system you have OTF activated (one of the layer is automatically reprojected but only for display purpose) – J.R Apr 16 '18 at 9:55
  • ok but this does not solve my issue – aaaaa Apr 16 '18 at 11:13
  • Maybe there is a problem with the projection of one of your file,are you sure they are really respectively WGS84 and OSGB1936 – J.R Apr 16 '18 at 11:25
3

If you use QGIS 3.0 the layers will automatically be reporoject as required.

1

based on @J.R. and @ndawson answers here how I solved my issue in QGIS 3.0:

Vector -> Data Management Tools -> Merge vector layers -> select the two layers with different coordinates into Input layers -> Run in Background

thanks

  • please accept one of the answers above if they solved your issue – underdark Apr 16 '18 at 17:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.