0

I am trying to do a very simple thing - convert a raster to a polygon where positive values are one set of polygons, and negative values are another set of polygons. The raster ranges from a minimum value of -8.00857 to a maximum of 9.4592. Here's what I have tried:

  1. Convert floating point Raster to Int (Int does not work).
  2. Multiply raster by a large number to remove decimal places then Convert Raster to Int (Int does not work)
  3. Reclassify into two classes: 0 for negative, 1 for positive (Reclassify does not work)
    1. Extract positive and negative values using Extract by Attribute and then apply steps 1-3 to them. Extract by attribute works, but none of steps 1-3 work.

The error messages do not indicate why the tools are not working.

  • Here is a link to the file on Google Drive: drive.google.com/open?id=1MXyY3wN6pU9hY23fBPxeiRJHH5YUKLwE – Brittney G. Apr 17 '18 at 19:22
  • Sounds like you are looking for just two polygons... Suppose your raster is a mix of positive/negative values distributed throughout the raster with no clearly defined zones? – ZrSiO4 Apr 17 '18 at 19:57
  • Reclass worked just fine using your data. What is your error message? – GBG Apr 17 '18 at 20:02
  • Yes, that is correct. When I say two polygons I mean two sets of polygons. One set of negative polygons and another set of positive polygons. – Brittney G. Apr 17 '18 at 20:02
  • @GBG the error message is 999999: Error executing function. May I ask how you entered the 'old classes' in order to have the tool work successfully? – Brittney G. Apr 17 '18 at 20:11
1

The following parameters resulted in a successful reclassification of your data. I also found Trouble with Reclassify tool when I did a Google search on 999999 error using reclassify.reclass paramaters

  • This is exactly what I have done and it does not work. How strange, I cannot think what else could be the issue. – Brittney G. Apr 17 '18 at 21:53
  • Thank you for looking at this. I may just restart my analysis from the beginning and see if I run into the same issue. – Brittney G. Apr 17 '18 at 21:54
  • Alright I just got it working. All I changed was the directory where I was saving it. Must be some kind of pathway issue. Thank you again. – Brittney G. Apr 17 '18 at 21:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.