0

I need to do an intensive viewshed and I am going to use our university SCC (Linux).

I am running a test viewshed with only 13 observers (just to build the code - eventually the script will be used on an OP shapefile with 700k points).

I've imported them into GRASS, and they are overlaying properly on the DEM. The input is simple (1.65m offset of the observer, no targets, 0.13 refraction. I've used these same parameters in ArcMap and it works fine.

Here is the code:

r.viewshed.cva -c input=pelop1arcm34b@PERMANENT vector=PI_14@PERMANENT output=test observer_elevation=1.65 memory=1000 refraction_coeff=0.13

For the output, I get this error:

WARNING: No points found, nothing to be exported
Note that the routine is constrained to points in the current geographic region.
Calculating "Cumulative Viewshed" map
ERROR: Raster map not found
Traceback (most recent call last):
  File "C:\Users\nsusm\AppData\Roaming\GRASS7\addons/scripts
/r.viewshed.cva.py", line 181, in <module>
    main()
  File "C:\Users\nsusm\AppData\Roaming\GRASS7\addons/scripts
/r.viewshed.cva.py", line 169, in main
    input=(",").join(vshed_list), output=out,
method="count")
  File "C:\PROGRA~1\QGIS2~1.18\apps\grass\grass-7.4.0\etc\py
thon\grass\script\core.py", line 421, in run_command
    return handle_errors(returncode, returncode, args,
kwargs)
  File "C:\PROGRA~1\QGIS2~1.18\apps\grass\grass-7.4.0\etc\py
thon\grass\script\core.py", line 332, in handle_errors
    returncode=returncode)
grass.exceptions.CalledModuleError: Module run None
['r.series', '--q', 'input=', 'method=count', 'output=test']
ended with error
Process ended with non-zero return code 1. See errors in the
(error) output.
1

The r.viewshed.cva addon script does not set the computational region. (Instead it allows the user to set any sub-region of the DEM. The module prints the message "Note that the routine is constrained to points in the current geographic region" to indicate this). My first guess it that the region settings do not cover the DEM at all, so you are getting the "No points found" error.

So start by setting the region with something like:

g.region -p rast=pelop1arcm34b

Then execute your r.viewshed.cva test

  • Thanks! I set the region, and now I am getting a different error: Note that the routine is constrained to points in the current geographic region. Memory manager registering memory in MM_IGNORE_MEMORY_EXCEEDED mode. – Natalie Apr 20 '18 at 16:41
  • Please check with g.region -p how many pixels you have and if the raster resolution is set as desired – markusN Apr 20 '18 at 17:19
1

Thanks! It turns out that my DEM was too large for the memory allocation that the tool defaults are set to. Changing it from 500 to 300000 worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.