0

I know the questions have been asked, but I can't make it through! So, I have uploaded a CSV with my Lat/Long coordinates (in degree decimals). Every points should be located in Quebec, but it all ends up in Africa...

I have tried many type of projection (EPSG CRS tested: 3857, 4326, 32187), making sure the Project and the layer added are with the same CRS. But, it doesn't work. What is wrong...? (I also made sure I have checked the right system to read all the accents in French - ISO-8859-1).

EDIT: I am using QGIS 3.0.1 (Girona), Windows. I have been using a previous version of QGIS without that problem before. I upload the CSV using "Add a delimited layer" and for my layer, clicking on semi-colon (;) works. However, it does not interpret my Lat/long the right way (Lat is Y and Long is X).

Here is a sample of my CSV:

Nom du nichoir  Latitude    Longitude   Notes
LAC001  45.72659349 -73.53560194    BFI: au stationnement à l'entrée
LAC002  45.74512655 -73.51659682    13 rue Charbonneau, Lachenaie
LAC003  45.74473    -73.51572   13, rue Charbonneau, Lachenaie. 
LAC004  45.73015563 -73.53572968    BFI, sur la butte à droite avant de passer la pesée
LAC005  45.73009159 -73.53487255    BFI, sur la butte à droite avant de passer la pesée
  • 2
    You should edit your question to add the name of the GIS software you're using and what you're doing to import your points. Those lat/longs are in Quebec, so there's nothing wrong with your coordinates. In that sample of your CSV your fields aren't actually separated by commas, that may be part of the problem. – Dan C Apr 18 '18 at 21:07
  • At least rest assured that you should be using 4326, or similar. Not 3857 or 32187. – phloem Apr 18 '18 at 22:38
  • Thanks! I have just edited my question. I have tried using commas (instead of points-dots) to separate my decimals, and unfortunately, it does not work... – Yong Lang Apr 18 '18 at 22:40
1

As has been said in the comments. The file you are opening is not delimited with commas, so it may just be a tab delimited text file. Try following these steps to get your points to present in QGIS.

  1. Outside of QGIS, open the text file in Excel (I assume you have access to Excel). Check that each of the fields and values sit in a single cell. IE: "nom du nichoir" should sit in Cell "A1" and "LAC001" should be "A2" etc. If all of the data seems to sit in one cell, try Step 2, otherwise move onto Step 3.
  2. If the data is all in one row / cell. Click on the "Data" Tab in the top ribbon and find "Text to Columns". Highlight all of your data and click the "Text to Columns" button. In the window that pops up, select "Delimited" as the description of your data. From the list of Delimiters, choose "Tab". You should see Columns show up in the "Data Preview" Window at the bottom of the form. If Tab does not create new Columns, cycle through each one until the data is in Columns you can understand. IF this still does not form the Columns that you are looking for, try using the "Other:" option and try different combinations. From the image you presented above, it looks like it is Tab.
  3. Once you have the data in Columns and Rows, check that the Latitude and Longitude are presenting correctly. As in they are in the correct fields. Select the "Save as" command in "File" menu and find the CSV Option. Save the file.

This will save the document as a true CSV file and you should then be able to use the QGIS Tool to import your points.

  • Thanks for going through all this detailed steps. However, it still doesn't work... I have even tried without the notes/comments. I have tried using Excel and NotePad. Still doesn't work. It is as though QGIS read the Lat/Long the other way around. I have even tried messing up with QGIS by reversing Lat/Long, just to see how it would react, and it still gets in Africa... – Yong Lang Apr 19 '18 at 18:29
  • I reinstalled an older version of QGIS and it worked... I still have no idea what when wrong. Thanks for your help, though! =) – Yong Lang Apr 20 '18 at 14:45
0

The fact that your lat/lon data is displayed in (or near) Africa points to the issue being that you have assigned a projected CRS to the data after importing them.

Right Click on the layer in the layers tab and in the layer properties screen, look at source.

enter image description here

If the coordinate system shown is not EPSG:4326 change it so that it is.

  • Hi! I already have done this step before, but it still doesn't work. I changed both project and layer CSR to make sure they were the same (EPSG 4326). – Yong Lang Apr 19 '18 at 18:14
  • I reinstalled an older version of QGIS and it worked... I still have no idea what when wrong. Thanks for your help, though! =) – Yong Lang Apr 20 '18 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.