1

Working in R Studio I'm executing the lines:

setwd("D:/Perfil_IBGE/4. IBGE") 
pasta = "1. Shapefiles Brasil" 
shapefile_brasil = "BRUFE250GC_SIR" 
shp <- rgdal::readOGR(dsn = pasta, layer = shapefile_brasil)

the result is: "no features found"

I work with Windows 10 and I checked about GDAL in my machine and I have this library installed.

What should I do?

closed as too broad by aldo_tapia, whyzar, Dan C, xunilk, tinlyx Apr 20 '18 at 21:33

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to GIS.SX! You can have a look at our starter guide to familiarize yourself further with our format. – nebi Apr 20 '18 at 5:47
  • I see 2 possible sources of error: special characters or layer name. What happen if you remove points and spaces in your names like D:/Perfil_IBGE/4_IBGE/1_Shapefiles_Brasil and what does the output of the command – nebi Apr 20 '18 at 5:49
  • and what does output the command ogrListLayers(".") (in the directory where you have the shapefile) ? – nebi Apr 20 '18 at 5:57
  • what does ogrInfo(pasta) return? This is similar: gis.stackexchange.com/questions/249781/… I'd try sf as well, but more help really needs access to this data set, is it publically available? – mdsumner Apr 20 '18 at 22:56

Browse other questions tagged or ask your own question.