9

I've looked all over the net and I'm wondering if there are any plans by the QGIS developers to integrate some of the newer versions of SAGA available in the repository and as binaries on the project's homepage into QGIS 3?

In a few instances, I've run into issues where an algorithm available in a more recent version of SAGA merits me installing it simply so I can have access to its tools. Having two installations of SAGA is a counterintuitive though.

Can anyone point me to a discussion thread that has possibly come up?

  • which version do you expect to get? on which platform/OS? Using the osgeo4w installer there is a saga 2.1.2-2 and saga-ltr 2.3.2-3 – Andreas Müller Nov 6 '18 at 11:44
  • @AndreasMüller Not coming from Windows so OSGEO4W doesn't interest me particularly but ideally, an integrated SAGA 3+ would also be available in those package binaries. What I'm interested in is versions above 2.X, both stable and LTR. There are quite a few algorithms that would be convenient to have in QGIS 3 and I can't seem to find any information or discussion that outlines plans to (or not to) integrate these newer versions. This isn't a technical question. – Trevor J. Smith Nov 6 '18 at 13:59
  • this sounds like a feature request to the qgis team would be an option, see: issues.qgis.org/projects/qgis/issues – Andreas Müller Nov 6 '18 at 14:58
  • I'm leaning towards closing this question as off-topic because it should be a feature request rather than a question on StackExchange. – underdark Feb 15 at 18:55
  • If it's alright with you, your post below essentially (and finally) answers my question. – Trevor J. Smith Feb 15 at 20:29
3

In 2017, it was decided to only support SAGA LTR. You can see the corresponding pull request here: [processing] support only SAGA LTR https://github.com/qgis/QGIS/pull/4118.

This SAGA mailing list post suggests that QGIS 3 should support SAGA 3:

Il 25/10/2016 11:58, Johan Van de Wauw ha scritto:

I'd like to keep in sync with QGIS LTR on the long term. Note that I will just do bugfixes and I don't intend to port back a lot of new features, so I don't think there will probably not be many releases after one year.

fine. so the plan is:

  • SAGA 2.3.x with QGIS 2.14/2.18 (whathever will be the LTR)
  • SAGA 3.x with QGIS 3 - which is a nice numbering fit, also ;) Thanks.

-- Paolo Cavallini

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.