0

I launch a PostGIS table via QGIS DB Manager tool [PostgreSQL 9.4.17 - PostGIS 2.1.8 - QGIS 2.18.19]. The table geometry is MultiPolygon. I can toggle both Toggle editing and Node tool buttons. When I click on map canvas in order to move nodes, I get the following message:

enter image description here

And the Log Messages Panel shows:

enter image description here

I can update attributes values and move features.

The issue seems to be on editing nodes only.

--

After having read several posts about editing a PostGIS table from QGIS, I've tried the followings without success:

  • Connection parameters to DB using postgres default user or other user
  • PostGIS table has both a primary key and an index on the geometry column
  • Function ST_IsValid() returns only TRUE values (no invalid geometries)
  • I can't connect directly via the "Add PostGIS layers" button's dialog for the DB is too big (over 50 schemas) and displaying the content is very long... Thus I use DB Manager instead.
  • Settings > Options > Digitizing: tried different tolerance values both in map units and pixels. Also tried to set "To vertex" or "To vertex and segments".
  • Settings > Snapping options: same tests.

What could I be missing?

  • 1
    The error is "Operation on mixed SRID geometries". Does your project use the same CRS than your table in PostGIS? – user30184 Apr 25 '18 at 9:46
  • Yes, both tables and project are SRID:3947 (tried with both on the fly CRS transformation on / off -> same issue). By the way, how can you see that the issue is a mixed SRID one? – wiltomap Apr 25 '18 at 9:52
  • By reading the error message that you attached. – user30184 Apr 25 '18 at 9:54
  • OK, missed this message... Anyway, the message systematically prompted when trying to edit nodes is the other one: Current transaction is aborted... – wiltomap Apr 25 '18 at 10:02
  • It just tells that transaction was aborted but what is interesting is why it was aborted. Perhaps QGIS tries to send the edited geometries without SRID or with a wrong SRID. If you can make PostGIS to log the SQL statements and see what happens. – user30184 Apr 25 '18 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.