2

I have tried to add buildings from WFS layer. https://kartat.espoo.fi/teklaogcweb/wfs.ashx (building layer is GIS:Rakennukset)

Geometry never shows up. However, map extent and data in attribute tables seems to be correct. Also, QGIS doesn't give any error message.

I have been so far able to track down that WFS layer contains different geometry types which seems to be problem for QGIS. I tried to save as GML and then select only polygons, but geometry still doesn't exist (extent and attributes are still fine).

Any tricks/tips?

4
  • What QGIS version are you using? The buildings in the layer you specified work fine for me and are displayed with the default settings.
    – 15Step
    Commented Apr 25, 2018 at 11:22
  • I use QGIS3 (3.0.0) and tried 2.18.14 too. OS X 10.12.6
    – Janne Salo
    Commented Apr 25, 2018 at 11:49
  • I also tried to edit geometry. I'm not sure whether visible elements are corners or center points but they disappear when I try to move them. No polygons are shown.
    – Janne Salo
    Commented Apr 25, 2018 at 11:51
  • Then the only problem I can think of is a projection issue. Try loading the layer in a new QGIS session (Vector->Add Layer ->Add WFS Layer from Server), and leaving the default settings for the WFS, with the CRS being 4326 (even though not ideal for this purpose).
    – 15Step
    Commented Apr 25, 2018 at 12:05

1 Answer 1

3

version 2.14 support is ok. Version 2.18 requires following service URL: https://kartat.espoo.fi/teklaogcweb/wfs.ashx?OUTPUTFORMAT=GML2

Data format have been recently modified to single geometrytype. Older multigeometrytype have been a problem for QGis.

1
  • This worked! Thanks! I wasn't aware of this change between versions.
    – Janne Salo
    Commented Apr 25, 2018 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.