0

I've successfully loaded in OS MasterMap to a PostGIS (2.4.4.1) database, and it appears in QGIS (2.8.9) fine.

Somewhere during the load process the FID from the raw files (the TOID) gets replaced with the ogc_fid field and appears to be a row number instead of the fid in the raw dataset.

Does anyone know how to include the TOID in the import process?

I've looked through the python files in the OS Translator II plugin directory, but my knowledge of this is very basic, so I'm a bit lost.

0

When using the OS translator plugin to import Ordnance Survey MasterMap Topography into your database you need to deselect the option for "Import boundary features (Ignore FID)."

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.