3

Changing Data source encoding through layer Properties worked well for me until version 3.0.x - now, the field is grayed out and shows only UTF-8. Our Data sources are quite mixed and I get spades, question marks etc. instead of East European characters when labelling. Is this feature broken in Early Adopter release or am I missing something?

Checking or unchecking value in Settings/Options/Data Sources/Data source handling - "Ignore shapefile encoding declaration" returns error "Wrong value for parameter "GRASS7 folder - Specified path does not exist".

2

After checking/unchecking value in Settings > Options > Data Sources > Data source handling > Ignore shape file encoding declaration, you should restart QGIS, and then Data source encoding (grayed out) field will be active.

And the error Wrong value for parameter "GRASS7 folder - Specified path does not exist is not about encoding. Just change Settings > Options > Processing > Providers > GRASS > 'Grass7 folder' and 'Location of GRASS docs' into actual GRASS folder. (probably C:/OSGeo4W64/apps/grass/grass-x.x.x folder)

  • Thank you for your answer Kadir, but Data source encoding is still grayed out in all my layers after restart. Prior to version 3.0.x, I had no problems with this setting in all my years with QGIS. Wrong parameter pop up window, I mentioned above, happen only after I try to change Data source handling from or to "Ignore shapefile encoding declaration" and hit OK to leave Options. Are you able to change Data source encoding in your QGIS 3.0? – user29347 Apr 26 '18 at 9:16
  • When I followed steps above, It worked. I use QGIS 3.0.1. – Kadir Şahbaz Apr 26 '18 at 12:27
  • I found out, that I have problem only on files, stored on server drive. If they are in use by other users, I can not change Data source handling in my instance of QGIS. Which is strange, as this setting does not change source file in any way and should not be locked by QGIS. – user29347 Jun 7 '18 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.