I'm trying to install QGIS 3.x using QGIS-OSGeo4W-3.0.2-1-Setup-x86_64.exe installer on my laptop running Windows 10, It gets most of the way through the install and hangs at: Creating folder C:\ProgramData\Microsoft\Windows\Start Menu\Programs\QGIS 3.0

which it creates but that's as far as it gets.

I tried using the OSgeo4W installer (osgeo4w-setup-x86_64.exe) and it gets hung on /etc/postinstall/python-core.bat.

I've used QGIS off and on for years and never had any problems.

Any Ideas?

  • How long do you let the installer "hang" before closing it? Also, does it hang up at the same point if you do "Advanced Install" and choose something else, like the nightly-dev version?
    – jcarlson
    Commented Apr 26, 2018 at 2:15
  • Not an answer, just an experience. I am using the Long term release (LTR) which is on purpose more stable. As today, it is the QGIS 2.18.19 'Las Palmas'. Being an on and off user you might not miss anything with this version. btw, I am still happy with 2.18.17 and I will not risk an installation problem without a need
    – Marco
    Commented Apr 26, 2018 at 6:59
  • I let the installer hang for 15 minutes before I killed it today. Looked at the process in task manager showed no activity. Then I unzipped the installer and ran the \QGIS-OSGeo4W-3.0.2-1-Setup-x86_64\$_25_\bin\osgeo4w-setup.exe from there and everything ran to completion, No shortcuts but it produced a runnable, properly configured qgis-bin-g7.4.0.exe. Not a perfect solution but totally functional.
    – seanmac10
    Commented Apr 27, 2018 at 17:01

1 Answer 1


So after trying around several hours I finally found a workaround. As the log of the installation states, the installation is complete, except for the start menu entry. But when I killed the setup and manually started C:\Program Files\QGIS 3.0\bin\bin\qgis-bin.exe it complains qgis_app.dll missing.

The solution can be found here QGIS 2.18 "The program can't start because qgis_app.dll is missing from your computer" It is simply to create a copy of qgis.bat.tmpl and rename to qgis.bat and then start qgis using qgis.bat. This worked for me with the latest QGIS 3 version on Windows 10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.