1

I have downloaded parcel files for several counties in Washington State, and am attempting to overlay them on the OpenStreetMap Standard base layer (which is in WGS84 Pseudo Mercator). The majority of the county layers were in WGS84 and automatically loaded into the correct extent/location, but some (such as King County) were in NAD83 (ESPG: 4269) is placed over West Africa in the OSM map.

What do I need to do to get this King County layer to load in the correct place on OpenLayers map? Or alternatively, how do I convert the file to the correct CRS using ogr2ogr?

Here are my project CRS settings: enter image description here

If I set the CRS for the layer to the correct settings NAD83 (EPSG:4269), the layer is not visible. (but doing zoom to layer still takes me to west Africa). If I change the CRS in layer properties to EPSG:3857, it becomes visible but is still in the wrong location.

enter image description here

I also tried saving the King County NAD83 layer as a new file with CRS set to WGS84 PseudoMercator, and using the extents laid out in the metadata files:

enter image description here

... but when I loaded it, I can't see the layer or make it visible no matter what CRS I choose for it. So then I gave up trying to do it in QGIS, and attempted to use some command line tools to try to convert/reproject the file.

Here is the output of ogrinfo for the King County NAD83 shapefile:

ogrinfo -so -al parcel.shp
INFO: Open of `parcel.shp'
      using driver `ESRI Shapefile' successful.

Layer name: parcel
Metadata:
  DBF_DATE_LAST_UPDATE=2018-04-06
Geometry: Polygon
Feature Count: 617501
Extent: (1218256.223500, 30932.680000) - (1577865.300000, 287704.244000)
Layer SRS WKT:
PROJCS["NAD_1983_HARN_StatePlane_Washington_North_FIPS_4601_Feet",
    GEOGCS["GCS_North_American_1983_HARN",
        DATUM["NAD83_High_Accuracy_Reference_Network",
            SPHEROID["GRS_1980",6378137.0,298.257222101]],
        PRIMEM["Greenwich",0.0],
        UNIT["Degree",0.0174532925199433],
        AUTHORITY["EPSG","4269"]],
    PROJECTION["Lambert_Conformal_Conic_2SP"],
    PARAMETER["False_Easting",1640416.666666667],
    PARAMETER["False_Northing",0.0],
    PARAMETER["Central_Meridian",-120.8333333333333],
    PARAMETER["Standard_Parallel_1",47.5],
    PARAMETER["Standard_Parallel_2",48.73333333333333],
    PARAMETER["Latitude_Of_Origin",47.0],
    UNIT["Foot_US",0.3048006096012192]]
MAJOR: String (6.0)
MINOR: String (4.0)
PIN: String (10.0)
Shape_area: Real (19.11)
Shape_len: Real (19.11)

I tried using ogr2ogr to convert it to WGS84, but got an error message:

ogr2ogr -f "ESRI Shapefile" -t_srs EPSG:3857 -s_srs EPSG:4269 'King County Parcels (WGS84, EPSG 3857).shp' parcel.shp
ERROR 1: Failed to reproject feature 0 (geometry probably out of source or destination SRS).
ERROR 1: Terminating translation prematurely after failed
translation of layer parcel (use -skipfailures to skip errors)

... I'm at a complete loss for what to do. I've looked through tons of tutorials and GIS Stackexchange posts on projections in QGIS, and seem to be missing something, but can't figure out what.

What am I doing wrong here, and how can I make this layer work with OpenStreetMap, and the other WGS84 layers?

2

The CRS of the King County parcel.shp is NOT NAD83. You see it from the extent which is obviously not degrees (what NAD83 uses), but meters or feet.

It seems that ogrinfo knows which CRS the shapefile has (State Plane Washington North feet), so you better leave it that way. EPSG code would be EPSG:2926.

The shapefile should import into QGIS correctly when EPSG:2926 is set to the layer. Once done, you can reproject it to a different filenmane and any other CRS based on NAD83, WGS84 or any GCS.

  • Thanks AndreJ! I read something in the .xml file that came with it that said it was NAD83, and saw where it said AUTHORITY["EPSG","4269"]] in the output from ogrinfo, and assumed that meant it was NAD83 EPSG:4269 ... How did you determine EPSG:2926 from the output of ogrinfo? – J. Taylor Apr 26 '18 at 7:33
  • To fix it, I just opened up a new empty qgis project, and loaded the King County layer by itself, reprojected, and then saved as WGS84. Then I was able to load it into the main project with the other shapefiles. – J. Taylor Apr 26 '18 at 7:36
  • If you type Washington North in the QGIS CRS search box, you get all CRS available in the EPSG database. Just pick the one with the right units (us-ft) and NAD83(HARN) in front to match the shapefiles metadata. – AndreJ Apr 26 '18 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.