Using an answer from another question, I learned how to use a Wingdings character in my point SLD. Now, I'd like to use a character from "Wingdings 3".

Here's the XML from the answer above that works great with Wingdings. (I switched the character to 116 as I want a triangle.

      <CssParameter name="fill">#000000</CssParameter>

Some of the combinations I've tried.

  • ttf://Wingdings3#116
  • ttf://Wingdings 3#116
  • ttf://Wingdings$203#116
  • ttf://Wingdings+3#116
  • ttf://Wingdings_3#116
  • ttf://WINGDNG3#116

What combination am I missing?


Looking at the code there is nothing there that makes a special case for spaces. So I would guess ttf://Windings 3#116.

Are you sure that is exactly what the JVM calls it on your server. You can check by going to Server Status -> Available Fonts.

  • Thanks for the tip to look in "Available Fonts". Turns out, "Wingdings 3" is not in the list. I did just install it, so I restarted the service. Still not there. Most likely my problem.
    – dangowans
    Apr 26 '18 at 17:13
  • I did however try "Arial Black", and a character did show up, so you are right, a space character is the answer. Now the question is getting the Wingdings 3 font in the list...
    – dangowans
    Apr 26 '18 at 17:13
  • Despite being installed on Windows, I had to place the font in jre/lib/fonts before it was picked up by Geoserver. After that, worked perfectly.
    – dangowans
    Apr 26 '18 at 18:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.