4

I try to connect to my postgres server, hence I got this failure Password fails

And following error:

2018-04-26T18:02:05 WARNING Traceback (most recent call last):
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_model.py", line 441, in rowCount
            self._refreshIndex(parent, True)
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_model.py", line 490, in _refreshIndex
            if item.populate():
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_model.py", line 167, in populate
            if not connection.connect():
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_plugins\postgis\plugin.py", line 103, in connect
            return self.connectToUri(uri)
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_plugins\plugin.py", line 109, in connectToUri
            self.db = self.databasesFactory(self, uri)
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_plugins\postgis\plugin.py", line 70, in databasesFactory
            return PGDatabase(connection, uri)
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_plugins\postgis\plugin.py", line 111, in __init__
            Database.__init__(self, connection, uri)
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_plugins\plugin.py", line 218, in __init__
            self.connector = self.connectorsFactory(uri)
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_plugins\postgis\plugin.py", line 114, in connectorsFactory
            return PostGisDBConnector(uri)
          File "C:/OSGEO4~1/apps/qgis/./python/plugins\db_manager\db_plugins\postgis\connector.py", line 128, in __init__
            os.remove(sslCAFile)
        PermissionError: [WinError 5] Access is denied: 'C:/Users/Matrix/AppData/Local/Temp/tmp_basic_{453d7688-e4d9-44e5-b2c5-51860a063061}.pem'

Any suggestions?

  • Can you see C:/Users/Matrix/AppData/Local/Temp/tmp_basic_{453d7688-e4d9-44e5-b2c5-51860a063061}.pem? Which permissions does it use? – Rodrigo Apr 26 '18 at 16:07
  • It was Read-Only, I changed it to not read-only, hence when I tried to connect again it points to a new temp_basic file.. – axel_ande Apr 27 '18 at 4:00
  • 1
    I just removed the connection and choosed No authentication and selected a basic setting and now it works in DB manager.. – axel_ande Apr 27 '18 at 4:45
  • I believe this was fixed in 3.0.2 – ndawson Apr 27 '18 at 20:25
  • Getting same error in 3.0.3 – user15741 Oct 15 '18 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.