In FME, I use the Aggregator to merge polygons based on one attribute (desnat in my example file).

  • When the output is Shapefile, multipolygons are created and all works fine.
  • When the output is OGC Geopackage or Spatialite, FME creates a
    GeometryCollection instead of multipolygons (and I can't use
    GeometryCollection with others GIS softwares like QGIS).

I tried to use the GeometryCoercer to force the geometry in fme_multi, but nothing is exported.


I tried to create a new attribute geopackage_type with value wkb_multi_polygon. The new attribute is created but the GeometryCoercer can't export anything.


If I remove the GeometryCoercer and I keep the AttributeCreator, the Geopackage is created but with a GeometryCollection and not multipolygons.

1 Answer 1


Not sure which versions you used? I was able to reproduce your problem in FME Desktop 2018.0.0.1 / QGIS Desktop 3.0.2

This behavior is likely to be caused by nested aggregates, created by the Aggregator as the source features already containes aggregates. For example the feature with idobj d3a4eed9-e042-4689-b050-d42c6bf6f248 is an aggregate from 2 areas.

FME Inspector 2018.0.0.1

Deaggregating them before aggregating solved this:

2018.0.0.1 FME Desktop Workspace


See the result in QGIS.

QGIS Desktop 3.0.2

  • 1
    Works well in FME Desktop 2018.0.0.2 and QGIS 2.18.19 + 3.0.2, thanks a lot!
    – romainbh
    May 4, 2018 at 15:03
  • Deaggregator must be set on "Flatten All Levels"
    – romainbh
    May 31, 2018 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.