I have been trying to import a CSV file into QGIS 3 on Linux. I end up with all my points at 0 lat and 0 long, off the coast of Africa. They should be in Florida. I cannot find this same issue in the forums. I have specified my X and Y, defined the geometry, and switched these around. I tried importing as degrees, minutes, seconds. I get the message that this layer has no projection specification, but I have one selected? What do I need to do?

enter image description here

enter image description here

  • 1
    I think you want EPSG: 4326. Pseudo Mercator isn't lat/long.
    – phloem
    Commented Apr 27, 2018 at 18:27
  • 1
    Another problem is that you have your X and Y values backwards in the screenshot. Lat = Y, Long = X.
    – Dan C
    Commented Apr 27, 2018 at 18:29

2 Answers 2


Your data is unprojected, that means that it is in latitude and longitude. Many coordinate systems are projected, which means these coordinates are transformed in various ways to a flat plane. During this mapping, the coordinates will change to be in a coordinate system with a different 0 point (in both X and Y), and the space between the increments of X and Y will be different.

Since your data is unprojected, and therefore still in latitude and longitude, you need to change the coordinate system of your layer to be in an unprojected coordinate system. You should check to see which coordinate system your data was measured in, but WGS84 (EPSG:4326) (not to be confused with WGS84 Pseudo Mercator (EPSG:3857), which you have selected) would be a good first guess.


I had the same issue. Switching from WGS84 (EPSG:3857) to WGS84 (EPSG:4326) solved the problem.

  • How does this Answer improve upon the answer with more information that makes the same suggestion?
    – Vince
    Commented Mar 3, 2021 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.