2

I have a QGIS project that has stopped showing the layers in the layers panel and the map, but they show up in the layer styling panel:

enter image description here

I have had this issue before, and reported it on the QGIS Users mailing list - but did not get any responses.

Here is the QGIS file here, with the user/passwords removed: https://www.dropbox.com/s/tfdbe02drj3uaua/Layers_Not_Showing.qgs?dl=0

Can anyone spot anything in the file that might be corrupted?

2

the element <layer-tree-group> (line 6) is empty, while it should contain the list of available layers. You can likely re-built it using the layer ID found in other parts of your qgs file + copy-paste from a valid (new) project.

  • I found the <layer-tree-group>, and tried to paste in the references to the layers that are missing, but the same behavior exists. I even tried opening this in QGIS 3.0 but with the same issue. – DPSSpatial May 3 '18 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.