2

This is a followup to Making QGIS toolbox tool available directly from toolbar? which I posted several days ago.

That question was more of a "how". This one is more of a "why".

Why are some QGIS tools only accessible via the Processing Toolbox, and not available directly via the normal menu?

For example, at 2.18.16 I constantly use the Frequency Analysis tool. But every time I use that tool I am required to click Processing > Toolbox > QGIS geoalgorithms > Vector table tools > Frequency Analysis.

Whew! It would be a lot easier if that tool was directly available on the main menu rather than hidden deep within the Processing Toolbox menu structure.

I'm not talking about plugins, but the tools that come with a default QGIS install.

closed as primarily opinion-based by nmtoken, user30184, BERA, ahmadhanb, whyzar May 2 '18 at 10:38

Many good questions generate some degree of opinion based on expert experience, but answers to this question will tend to be almost entirely based on opinions, rather than facts, references, or specific expertise. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Possibly because it's a tool that people don't use too often (will lead to chicken and egg discussion...) or historically because the processing toolbox was not part of original QGIS and has been bought in from (an)other(s) project(s)... – nmtoken May 2 '18 at 6:17
  • 1
    Are you actually interested in the history and design of QGIS or is it a rhetorical question? – bugmenot123 May 2 '18 at 8:44
  • @bugmenot123 QGIS history and design... – Stu Smith May 2 '18 at 12:52
4

Processing Toolbox menus & buttons are easy to configure in QGIS 3:

Settings Options Tab Processing

enter image description here

  • What OP should do but not what OP asked for. :} – bugmenot123 May 2 '18 at 8:45
  • Is that menu path broken? Looks like some bug in formatting. – bugmenot123 May 2 '18 at 8:45
  • 2
    Nah why is because it was not implemented in 2.x yet... Menu path is not broken, the & is due to the menu quickkey, look for the underlined letter in the menu and hit ALT-O to expand the Vector menu. – nielsgerrits May 2 '18 at 9:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.