4

I am trying to generate a DEM mosaic to publish via a WCS using MapServer. Unfortunately I can not remove the NODATA. In MapServer's own tutorials and discussion groups suggest PROCESSING "NODATA = 0", but it does not work.

Has anyone here ever had such a problem, if so, did you solve it?

2
  • 1
    Please explain what you want to do and include links to your sources. Is your use case like this geoexamples.blogspot.fi/2013/11/…?
    – user30184
    May 4, 2018 at 6:04
  • It seems to me that the PROCESSING "NODATA = 0" directive might just be saying that the nodata value (to ignore) is 0. Is 0 your nodata value?
    – nmtoken
    Jul 28, 2020 at 12:20

1 Answer 1

0

For WCS 2.0 you can set this in the METADATA of a LAYER for specific format options:

METADATA
    # this metadata item is in the format wcs_outputformat_{OUTPUTFORMAT}_creationoption_{FORMATOPTION}     
    "wcs_outputformat_GEOTIFF_INT16_creationoption_nullvalue" "0" # WCS 2.0 only
END

For WCS 1.0 the following METADATA option should be used:

METADATA
    "wcs_rangeset_nullvalue" "0"
END

There is a test repository and details at https://github.com/geographika/wcs-test with more details and options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.