1

I am trying to locate LAS points which is within a specific distance (25cm or 50cm) from the 3D points in a feature class. This is exactly what the Locate LAS Points By Proximity tool should do. My problem is just that I get a 999999-error, and I have no clue why.

My input files are a Las Dataset and a 3D point feature class and I have tried a lot of combinations of settings and outputs, but with the same error message every time.

I can only drag-and-drop my point feature class into the tool - if I browse to find it in the windows folder, then it is not visible. Maybe that can be a hint for solving the issue.

Tool inputs (I also tried without changing class codes and calculating statistics but again with error)

Message in geoprocessing result

2

I got the same error but was able to resolve it by applying the Add Z Information tool to the proximity dataset which added a Z field to the attribute table. Note the proximity dataset must be a Z-enabled feature class.

1

Try using the tool Make Feature Layer first. There you should be able to create a layer that can be used as input to geoprocessing tools that accepts feature layer as input.

Another option is to use ArcPy, where your code could be something like:

import arcpy
from arcpy import env

arcpy.CheckOutExtension('3D')
env.workspace = 'C:/test'
arcpy.LocateLasPointsByProximity_3d('Proximity_test.lasd','GCP_test.shp', 
                                    search_radius="50 Centimeters", 
                                    count_field="LAS_count",
                                    out_features="Test_result.shp"
                                    )
  • Thanks for the suggestions. I tried the Make Feature Layer, but it results in the same error.. and I am not used to work with ArcPy so I'd rather solve it with the tool if possible. – Mikkel May 7 '18 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.