4

I am attempting to run a simple Select by Attribute on a large File Geodatabase feature class (1,751,339 polygons) in ArcMap 10.6, but the query returns extra, incorrect records along with the features that have the attribute value I'm interested in. For example, when I search for soils in the Mollisol taxonomic order with component.taxorder='Mollisols' the query selects those features along with other, incorrect features that correspond to different soil types (e.g., Alfisols).

These are the NRCS SSURGO soil data, and the attribute in question was joined to the map unit polygons from the "component" table in the geodatabase. I have tried rebuilding the joined table from the original source data, but get the same results. Per DanC's suggestion, I also tried similar queries such as component.taxorder IN ('Mollisols') and component.taxorder LIKE 'Mollisols%', but those return the same errant search result.

Apparently some users experienced a similar problem when querying long integers in ArcMap 10.0, but that bug has supposedly been resolved. I can't find any reference to this problem in ArcMap 10.6.

If anyone else has experienced this, have you found any fixes or workarounds?

Errant Query

  • Are you running this selection on a joined table? – MapHound May 4 '18 at 16:58
  • Yes, nearly all the attributes are from a table joined to the polygon layer. Edited question to reflect that. Is this a known issue with attributes from joined tables? – lambertj May 4 '18 at 17:00
  • Have you tried using a different query that should produce the same results, for example component.taxorder LIKE 'Mollisols%' or component.taxorder IN ('Mollisols')? Does a Definition Query with the same criteria also produce wrong results? Can you export the joined table as a new table and try the same selection query? – Dan C May 4 '18 at 17:16
  • 1
    @lambertj Well, I was curious about the behavior if you created a new field on the feature class, populated it with the table field, then ran the same select by attributes on the feature class field instead...if you get the same result error or not. – MapHound May 4 '18 at 18:41
  • 1
    @MapHound Creating a new field on the feature class, populating it via Field Calculator, and re-running the select by attributes on that new field worked perfectly. Any idea why the results differ from the joined field? At any rate, can you post this as an answer so I can accept it? I'm sure this will help others with similar issues. – lambertj May 4 '18 at 19:37
2

Try creating a new field on the feature class, populating it using Field Calculator with the table field data, then re-running the select-by-attributes on the feature class field instead to see if that works better.

I have no idea why that might work, other than my prior experience with bugginess with joined tables. It crossed my mind as an option to try.

  • @lambertj You're welcome - glad to hear! – MapHound May 4 '18 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.