0

I'm trying to do a quite simple operation, an intersection, but when I run it it says : "Input layer A contains invalid geometries (feature 1745). Unable to complete intersection algorithm."

I'm new to GIS so I have little idea what this could mean and where I could search.. How can I determine what is wrong?

  • 2
    what software are you using? – Ian Turton May 5 '18 at 8:53
  • 2
    Welcome to GIS SE. As a new user, please take the Tour, which explains how our "Focused question / Best answer" model operates. In order to be answered, questions need to describe the problem thoroughly, which would include the operating system, software, data, and exact command, in addition to the error message. Given the error message, it is likely you'll be asked if you've done any validation or repair on input layer A, especially feature 1745, and to include the geometry's vertex stream in the question. – Vince May 5 '18 at 10:15
  • Oh, of course, I'm using QGIS 2.18, tried with 3.0 also but same issue – Murena May 5 '18 at 19:05
1

in order to know what is wrong in your shapefile you can run Check Validity from the drop-down Vector --> Geometry Tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.