I have downloaded QGIS 1.8 and installed it on my windows 7 system. When I click on the desktop icon, nothing happens.

I am currently running QGIS 1.7.4 with no problems and the installs of previous versions have always worked with no problems. I'm not sure what's going on here. Has anyone else experienced this and have a solution?

closed as too localized by underdark Sep 25 '12 at 6:05

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    workslike a charm for me on win 7. Did you previously uninstall version 1.74 before installing 1.8?.Are you using the standalone-installer?. Suggestion: If both versions are installed try uninstalling both. delete c:\user\.qis manually and do a fresh install with the standalone installer for version 1.8 – Kurt Jun 26 '12 at 6:05
  • correction: delete c:\user\username\.qgis maybe it is also named c:\users\username\.gis (I have a german win 7, where it is called benutzer) – Kurt Jun 26 '12 at 6:27
  • There is something else going on here. I have 1.8 installed on my laptop at work, and it starts fine. I have it installed on my workstation at home, and it will not start up. Both are Windows 7 machines. Both were installed using the OSGeo4W installer. At home on startup, the .bat file runs and splash screen comes up, then disappears and no further process runs. @underdark, any ideas to test? – Get Spatial Jun 26 '12 at 17:23
  • Did you have any other (non OSGeo4W) version installed at any point? Then a clean uninstall should help. Also make sure once more the C++ Redistributable is installed. If nothing has changed on your system since 1.7.4 worked, that shouldn't be the cause but it's usually the problem if QGIS doesn't launch. – underdark Jun 26 '12 at 17:37
  • Was the QGS 1.7.4 also installed with OSGeo4W installer? The installer can be the problem. It copies a load of zipped stuff in the ..\user\downloads\ folder, maybe the .bat files responsible for opening bz2 packages and copying the files couldnt handle it. Try using the standalone installer. – Marty Sep 25 '12 at 6:12

Try install the Microsoft C++ 2005. The QGIS need this aplication to run


  • If 1.7.4 works, the C++ package cannot be missing. – underdark Jun 26 '12 at 14:33
  • Hello underdark I have the 1.7.4 installed and when I upgrade to the 1.8 I've noticed that the OSGeo4W installer have installed the C++ package (!?). That's why I refered if the package are installed. – MapasPT Jun 27 '12 at 9:48

I think this has something to do with the file paths in your qgis.bat. Could you post the contents of your qgis.bat? For example, if it looks like the following

 @echo off

SET OSGEO4W_ROOT=C:\Program Files\Quantum GIS Lisboa
call "%OSGEO4W_ROOT%"\bin\o4w_env.bat
call "%OSGEO4W_ROOT%"\apps\grass\grass-6.4.2\etc\env.bat
@echo off
path %PATH%;%OSGEO4W_ROOT%\apps\qgis\bin;%OSGEO4W_ROOT%\apps\grass\grass-6.4.2\lib
start "Quantum GIS" /B "%OSGEO4W_ROOT%"\apps\qgis\bin\qgis.exe %*\

You might want change the path in

SET OSGEO4W_ROOT=C:\Program Files\Quantum GIS Lisboa

to its short name version

SET OSGEO4W_ROOT=C:\Progra~1\Quantu~2

or whatever its short name is. Save and then try loading QGIS again. It seems to be having problems with paths that have spaces. I hope that helps.

  • If Qgis 1.7.4 is already installed, it should most probably be Quantu~2. Otherwise the old version will be started. – AndreJ Sep 25 '12 at 5:44
  • Fixed it to reflect that the path names changed. Thanks for pointing it out. – R.K. Sep 25 '12 at 5:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.