I'm wondering if there is a way to prevent SAGA from generating temporary files. For example, if I just want to generate a slope map using SAGA I have to wait for all 11 other grids to get processed. Is there a variable I can set or enter that would prevent them from even being created?

The only option we seem to be given is to not add them, but that doesn't prevent having to wait for them to process. I'm processing huge LIDAR raster files, so it would be great to avoid all this unnecessary wait time.

enter image description here

2 Answers 2


Should be possible to do if you feel like hacking your qgis install.

  • 1
    For reference: github.com/qgis/QGIS/pull/6939
    – ndawson
    May 6, 2018 at 23:50
  • Thanks Nyall, I also tried passing "None" through the dialog box and I think it works that way too because the Python log shows they weren't created either. Going to keep testing and will try this hack to see if there's any change in processing time. May 13, 2018 at 23:29

At least in the GRASS version of this algorithm, there is a Skip Output option in the ... button next to each output.

enter image description here

  • Yes, that is an option in my Grass tool too but not Saga. I'll see if I can make GRASS work. Unfortunately, SAGA likes grids made with SAGA modules. I was getting errors using slope calculated with the default slope but not SAGA. Thanks! May 6, 2018 at 1:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.