0

I am a beginner with GIS software, but know some basics of the OSM format.

So I want to create a custom map for a game. I already created a heightmap from DEM data, but I need to color the water bodies in black. The way I wanted to do this is to create a custom map from OSM data, which shows only the water bodies and then overlay it with the heightmap using Gimp or something similar. The Region I want to map is approximately 70km * 70km and will probably be scaled down later.

So I thought this would be simple, but after several hours and trying out several tools I am still not anywhere near the desired result. It seems like the available tools are straight out of the 90's and dying when used with the amount of data I want to process or the development has been discontinued and some bugs make it impossible to use.

I tried the following tools:

  • Merkaartor (0.18.3 on Linux): It takes more than 10 minutes to load the .osm file I have downloaded.
  • QGIS (2.18.16, Linux): This seemed to be the most promising solution so far. I managed to download the OSM data, create the database and layers. Unfortunately for unknown reasons some water bodies are simply not shown. The current Windows version of QGIS just hangs in the last step of the setup and then is missing some .dll file.
  • Maperitive: I have read that it should be able to do this, however the rule system is quite complex and it seems a bit of an overkill.
  • TileMill (v 0.10.1, Windows): This was another promising software, but soon it turned out that there were some bugs and I could not really figure out how to get it to do what I want. Overall the project seems to be discontinued and refers to Mapbox Studio.
  • Mapbox Studio: At least I could export a png with the data I wanted. However as I cannot export an unlimited amount of data I would rather have an alternative. Plus the export dies when i request the area with 7k x 7k pixels.

Is there an easy way to archive what I want that I have overlooked? As a software developer all of this software seems so odd to me. It seems so hard and time consuming to archive a seemingly simple objective.

EDIT: Added my experience with Maperitive.

  • Option 2 'QGIS (2.18.16, Linux)' you might want to use QGIS 3.02 64 bit as there is better rendering and multi-thread is supported. see gis.stackexchange.com/questions/120185/… – Mapperz May 6 '18 at 14:18
  • In my experience, Maperitive comes with a bunch of built-in rules that renders OSM out of the box. and it can deal with DEM data too. – AndreJ May 6 '18 at 16:54
  • @Mapperz QGIS 3 is not available for my distro, when compiling it I run into an internal compiler error and with the windows install I run into this issue: gis.stackexchange.com/questions/280870/… – T. Watzl May 9 '18 at 13:31
  • @AndreJ I have used Maperitive sucessfull now and managed to do the full workflow (including DEM data) in Maperitive. However it was not trivial. I am planning on putting together a howto guide. Is there a way to print the current geo bounds in maperitive, when you set them via dragging the bounding box? – T. Watzl May 15 '18 at 18:42
  • @T.Watzl please open a new question for this. I have not used maperitive for some time now. – AndreJ May 16 '18 at 9:56
2

Concerning QGIS, this topic (including the reason for missing water features) is covered by How to make an editable City Map from OSM data?

  • Thanks. I am trying to follow you blog entry. Unfortunately the QGIS provided by Fedora seems to be missing the toolbox plugin and I could find nowhere to download it. Additionally all other ways to install QGIS (Windows, compile from source) did not work. Do you have a download link? I could not find the plugin in the plugin database. – T. Watzl May 9 '18 at 14:29
  • The processing toolbox is installed by default. You might have to enable it gis.stackexchange.com/questions/146591/… – underdark May 9 '18 at 17:21
  • Using the QGIS version Fedora provided it was not available in the plugins list. When I finally managed to get QGIS working under Windows 10 (see gis.stackexchange.com/questions/280870/…) I followed the tutorial you provided and when fixing the riverbed polygons, QGIS stopped working after 40%. Since that point I have given up QGIS. It was just too time consuming for me. – T. Watzl May 15 '18 at 18:40
-1

try JOSM, you can download OSM, edit and convert to others formats

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.