1

Yum installed postgrepsql 10 and postgis 2.0 on a centos 7 host. Got this error while creating the postgis extension on a DB:

could not open extension control file "/usr/pgsql-10/share/extension/postgis.control": No such file or directory

The postgis.control file on the Centos 7 is actually on /usr/share/pgsql/extension/postgis.control

How should I resolve this? Will creating a soft link be enough?

  • 1
    2.0 is fairly old now, and is not compatible with postgres 10.. you might want to try with 2.4 – JGH May 7 '18 at 18:44
  • thanks for the reply. Yes I installed it from the wrong repo. I have epel and pgdg10 repo both enabled and it ended up install from epel repo. – user1941319 May 7 '18 at 18:56
0

I have both epel and pgdg10 repo enabled. Disabling the eprl repo before installing postgis will install the proper postgis rpms for postgresql-10.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.