9

In QGIS 2.8 there is a clear button to 'enable on the fly CRS transformation' in the "project properties" for a new project. Seen here: enter image description here

But in QGIS 3.0, I cannot find it to save my life.

enter image description here

Can anyone help?

  • It is on by default issues.qgis.org/issues/11644 – user30184 May 7 '18 at 19:10
  • I couldn't comment on the comment from gisnside but I found it to be very useful +1 if I could. Also I agree with AnsreasK, being able to turn off OTF would be very help to quickly identify layers with different projections as I do this often. – Scott Mar 2 at 0:53
  • It would be great if someone could update the documentation and tutorials for 3.x that still refer to enabling OTF transformations. docs.qgis.org/3.4/en/docs/user_manual/working_with_projections/… – Adrian Birch Mar 23 at 11:58
  • I have used on the fly reprojections for a few years with QGIS and it always worked very well until the NOOSA release. Now when I bring in raster files they don't reproject to the county coordinate systems that I have used for years. They used to in older versions of QGIS. It doesn't seem to matter if I bring in the rasters from and ESRI server or a local server. Has any one else had this problem or found a solution other than installing an older version of QGIS? – stephennicholson May 2 at 16:44
  • 1
    This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – whyzar May 2 at 19:07
19

In QGIS 3.0, on-the-fly (OTF) reprojection is always enabled (https://issues.qgis.org/issues/11644).

  • 1
    There is no option anymore to deactivate the the OTF? This is crazy! For a GIS program this is ridiculous. – AndreasK Nov 19 '18 at 13:41
  • @AndreasK Can you list any cases when OTF reprojection should NOT be used? – Aurus Huang Nov 26 '18 at 0:57
  • 9
    Every time when there is the possibility that your layers are in a different coordinate system! With the OTF ON&OFF you could immediately see that you have layers with different coordinate systems in your project. As I gave courses to hundreds of people, I know that people look for super-easy ways. That said QGIS3 is in many many way more complicated (more clicks) than QGIS2. The new checkbox (instead of OTF!!!) --> "No Projection" is almost unexplainable and doesn't make sense in 99.999% of all cases. – AndreasK Nov 26 '18 at 18:31
  • Deactivating this option is good to see the source coordinates : I support the fact it's very useful. @AndreasK the workaround is just to select "no projection" for your project ;) – gisnside Feb 27 at 14:00

protected by Community May 2 at 19:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.