1

I am doing a hotspot analysis for chicken spatial distribution in QGIS using Ubuntu. I have already installed the repositories used for hotspot analysis. However, an error occurred after I chose a layer and its attribute table. It says:

An error has occurred while executing Python code:

ValueError: Illegal field requested in GetField() Traceback (most recent call last): File "/home/envisci/.qgis2/python/plugins/HotspotAnalysis/hotspot_analysis.py", line 565, in run u.append(geometry.GetField(C)) File "/usr/lib/python2.7/dist-packages/osgeo/ogr.py", line 4707, in GetField raise ValueError("Illegal field requested in GetField()") ValueError: Illegal field requested in GetField()

Python version: 2.7.12 (default, Dec 4 2017, 14:50:18) [GCC 5.4.0 20160609] QGIS version: 2.14.5-Essen Essen, exported

Python Path:

/usr/share/qgis/python/plugins/processing /usr/share/qgis/python /home/envisci/.qgis2/python /home/envisci/.qgis2/python/plugins /usr/share/qgis/python/plugins /usr/lib/python2.7 /usr/lib/python2.7/plat-x86_64-linux-gnu /usr/lib/python2.7/lib-tk /usr/lib/python2.7/lib-old /usr/lib/python2.7/lib-dynload /home/envisci/.local/lib/python2.7/site-packages /usr/local/lib/python2.7/dist-packages /usr/lib/python2.7/dist-packages /usr/lib/python2.7/dist-packages/PILcompat /usr/lib/python2.7/dist-packages/gtk-2.0 /home/envisci/.qgis2//python /home/envisci/.qgis2/python/plugins/gearthview/ext-libs /home/envisci/.qgis2/python/plugins/DigitizingTools/tools /usr/share/qgis/python/plugins/fTools/tools /media/envisci/msguimalan/RA

How can I resolve this error?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.