1

I have a mif file that contains a field track full of vertexes. Said file is read and reprojected used EsriReprojector from ETRS89 to WGS84. A simple geometryfilter is appended to redirect resulting data to a file database.

However, when i run the ETL tool, the resulting geometry is a flat line.

It seems the problem is generated by the reprojector. I've tried others, like CSMapReprojector and standard FME Reprojector but none of them work

1

When you say "flat line" do you mean it is 2D instead of having Z values? If so my initial thought is that Reprojector transformers should leave the Z values intact, but that if you want it to be handled in the reprojection, then the CSMapReprojector is the one to use. It's the only reprojector transformer with a Z value parameter.

If it's a flat line in that it's straight (horizontal with the same Y values, or vertical with the same X values) that's probably down to the writing of the data. Have you inspected the data after it's been reprojected but before it gets written? That would confirm where the problem occurs. In fact if you use Writers > Redirect to Inspector and the results of that look OK, then it's 99.9% certain that the writer is at fault.

If it is the writer, check out its parameters. One of the settings is to define whether the data has Z values or not. Set that to Yes. If you have it set to Auto then a single 2D feature will force everything to 2D.

Also check out the Table Creation parameters (on the writer feature type/table). There is one there for x/y precision and I can imagine it would get set up for metres, but then you reproject to degrees and it no longer fits.

If that doesn't help, can you post a couple of screenshots so we can see what is happening and what settings you have?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.