0

I need to overlay two shapefiles: US counties over each other to make a spatial query. One is NAD83 unprojected, the other is US Continuous Albers Equal Area Conic (1860 historical US county boundary). I set up Dataframe for the Albers to NAD83 but does not overlay due to Layer Extent (one is meter (figure 1) and the other is dd (figure 2 below).

How do I change the Layer Extent of the existing layer (in this case, the Abers one)?

enter image description here

enter image description here

  • The issue is not with the unit nor the projection, but because the coordinates of your 1st layer are wrong (3km * 2km seems small for the size of a country) – JGH May 9 '18 at 18:09
  • Is there way to change the size of the coordinates? – JoyS May 10 '18 at 15:06
  • 1
    I'm wondering if the first layer, supposedly in Albers, is using kilometers rather than meters. JoyS, try modifying the coordinate system and set the units to meters of that dataset. – mkennedy May 10 '18 at 17:42
1

Set the map (dataframe) to the projection you want, add in a basemap like streets, add one layer at a time to see if it show up in the right location. If it doesn't, then it's undefined or defined wrong, you need to set it's projection to what it is, not what you want it to be. If they both show up in the correct location the project on the fly is working and they are properly defined.

If the dataframe is in the projection you want, to reproject them to the same projection, right click on the layer, export, and choose the dataframe projection. Your new featureclasses should now be in the same projection and units, for geoprocessing.

  • I did export this with the same dataframe but still does not fit the basemap although the coordinate system is the same as the dataframe. The issue is the layer extent of the new feature is much smaller than the one that fits the dataframe. How can I change the layer extent. The new extent is 37.51dd (top) compared to the one, 73.44dd (that fits perfectly to the basemap. – JoyS May 10 '18 at 15:05
  • The layer that doesn't fit. Did it overlay the base map before? I'm guessing it's defined wrong in the first place. If it starts wrong the math doesn't work and it ends up in the wrong place. I'd check it against something I know is right. – Bill Chappell May 10 '18 at 15:15
  • Option 2. Edit the wrong one, look at spatial adjustment, you can create links from the bad fitting one to the one that's correct and "Adjust" it to fit, then save it. Very similar to GeoReferencing images but with vector data. – Bill Chappell May 10 '18 at 15:18
  • No. It won't overylay the basemap before. Something the scale they created the layer is smaller extent. Your second suggestion, georeferening make sense. So I have to make the wrong layer to a image format and then, do georeferencing. Or is there way or a tool to adjust it to fit with vector data (without save a vector in a png first) . Thanks very much. – JoyS May 10 '18 at 18:24
  • No need to make a PNG, keep it in vector format. Look at desktop.arcgis.com/en/arcmap/10.3/manage-data/… it can "Warp" the data and keep it in vector format. – Bill Chappell May 10 '18 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.