0

I am trying to iterate through a set of 50 points of GPS data. Each have their own unique Estimated Horizontal Accuracy. What I am looking to do in ModelBuilder is create a model so that it creates a buffer for each unique value (using Iterate Row Selection or some other iterator), and then combine them all based on collection site at the end.

I have tried iterating based on multiple values (site name and horizontal accuracy, with the horizontal accuracy at the top of the list), but it did not read properly. I also did just the horizontal accuracy, but that also did not work. Every time I run it, it gets to the buffer part, and then ArcMap crashes with an error report. I think this is because of a runtime error, and, therefore, I have a parameter that is wrong in my buffer tool. The horizontal accuracy value is a Double value in the original table/data layer.

I have "Get Values" set to read the Sitename attribute.

Any ideas?

enter image description here

  • How is the buffer parameter formatted? Does it contain the unit, or are you calculating that somewhere before the input into the buffer tool? If you are just using an unknown or unspecified linear unit, the tool indicates that "the linear unit of the input features' spatial reference is used". I'm assuming these are in GCS, so perhaps you just need to specify a linear unit instead of letting it default? – smiller May 9 '18 at 20:25
  • The coordinate system for the FC is State Plane (Feet). The data collection was done in meters using ESRI's Collector App. It is just a decimal with no unit. I noticed, after I attach the value as the distance, the entire field goes dim when I click on the buffer block of the model. Come to think of it, using the buffer tool using arcpy has had me write the distance and unit together as a string. I will create another field and see how that goes. Thanks! – Smithw1 May 9 '18 at 20:47
1

Double-check the linear unit that is being specified in the buffer distance parameter. If it does not contain a unit, the tool indicates that "the linear unit of the input features' spatial reference is used".

  • This fixed my crash report issue, but now I get an error that says "The Buffer distance field cannot be empty." I calculated the second field using str(Accuracy Field) + " Meters." I also tried it without the space between the 2 values, but still nothing. I double checked the unites in the Buffer tool; they are the same. I even tried putting meters in quotes in the attribute field, but still nothing. I am not sure what to try next. – Smithw1 May 10 '18 at 13:52
  • hmm - have you tried calculating a field with the value in Feet (to match the spatial reference) and using that as the buffer distance field (leaving off the units)? – smiller May 10 '18 at 14:06
  • 1
    I tried switching it to Feet because I noticed that whenever I connect my Value variable, the Buffer tool resets back to feet. It did not work either. Having just the number causes the crash report. However, I created a second attribute field with the Float type and field calculated the original Horizontal Accuracy field. This worked and it properly used the buffer value. It may have something to do with ESRI's Collector data schema. I am not sure, but at least it worked. I did not need to put the unit, but it did default to Feet. I will have to convert my values. – Smithw1 May 10 '18 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.