0

I'm trying to simply combine 5 different rasters in raster calculator to do a site suitability analysis using this map algebra expression:

"bo_reclasstemph3" + "bo_reclassph" + "bo_raster_precip" + "bo_raster_elevation" + "bo_raster_soiltext"

However, I keep getting this error message:

Messages Executing: RasterCalculator ""Reclass_ph3" + "Reclass_annualmintemp" + "Raster_precipitation" + "Raster_soiltexture" + "Raster_elevat"" T:\Barnett_GIS_Spring18\Agroforestry\California_Agroforestry.gdb\final1_plzwork Start Time: Wed May 09 15:22:46 2018 Raster(r"Reclass_ph3") + Raster(r"Reclass_annualmintemp") + Raster(r"Raster_precipitation") + Raster(r"Raster_soiltexture") + Raster(r"Raster_elevat") ERROR 000539: Error running expression: rcexec() Traceback (most recent call last): File "", line 1, in File "", line 5, in rcexec File "c:\program files (x86)\arcgis\desktop10.4\arcpy\arcpy\sa\Functions.py", line 4329, in Plus in_raster_or_constant2) File "c:\program files (x86)\arcgis\desktop10.4\arcpy\arcpy\sa\Utils.py", line 53, in swapper result = wrapper(*args, **kwargs) File "c:\program files (x86)\arcgis\desktop10.4\arcpy\arcpy\sa\Functions.py", line 4326, in Wrapper ["Plus", in_raster_or_constant1, in_raster_or_constant2]) RuntimeError: ERROR 999998: Unexpected Error.

Failed to execute (RasterCalculator).
Failed at Wed May 09 15:22:46 2018 (Elapsed Time: 0.08 seconds)

The day before I completed the same process with the same data but different rankings and it worked:

Working raster calculator

  • 1
    I tried it on a different computer and had the same problem. Also I retried the same raster calculator query on the rasters that worked before and they no longer work... I am getting the same error message. So something must have happened in between then and now... – Annab31 May 9 '18 at 22:02
  • 1
    Please provide all error messages as text rather than pictures. – PolyGeo May 9 '18 at 22:11
  • Where is your code? That would be quite helpful. Are you sure you set your workspace correctly so that the rasters can be found? Try creating each raster object one by one then sum the objects, without code it's hard to explain further. Are all the rasters in the same spatial reference, cell type and extent? – Michael Stimson May 9 '18 at 22:28
  • I'm just trying to do a simple addition map algebra expression and I added it above so you can see. I have set the workspaces to the correct geodatabase but I'm still having the issue. – Annab31 May 9 '18 at 22:36
  • a) cell statistics (SUM) will do the same thing b) check extent settings c) try output to GRID stored in folder/ – FelixIP May 9 '18 at 23:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.