7

I'm having problems creating new shapefiles - in QGIS 2.14.20 any new fields I create and any associated data are not saved. I've now got the same problem in QGIS 3.0, but there I get a message saying layer creation failed. There is an error message but it just seems to say 'warning :' But under OGR I get:

2018-05-10T10:44:30 WARNING Creation of OGR data source test.shp failed: Failed to create file test.shp: Permission denied

I am running on an iMac High Sierra 10.13.4. I also sometimes can't save projects. I am the only user of this machine and have admin privileges, and am trying to save the shapefiles and projects locally.

  • Navigate to the folder you are trying to save in and can you create any files there? – HeikkiVesanto May 10 '18 at 10:07
  • yes, no problem, its just on the local disk – Cameron May 10 '18 at 10:11
  • actually the creation fails before I give a file path – Cameron May 10 '18 at 10:17
5

Before trying to save the file, click on the folder button at the right of the filename entery box and select a writeable folder for the save.

  • This was my problem. I just typed a name like Nodes and got the Failed to create file Nodes.shp: Permission denied error. What worked was clicking the ... button next to File name field and selecting a writable directory for the shape file there. – lexicore Oct 17 '18 at 4:41
1

I got some professional help in the end to fix this. It seemed to be a problem with pathways because the QGIS3 install for mac had overwritten some settings. A 'deep clean' uninstall and fresh install and I am almost up and running again.

1

Just like said above, when entering the name of the Shapefile, click on the button (...) on the right hand side, and choose the location folder to save.

I was having the same issue, as per default it was saving to a random folder, and when I chose the right folder on the server it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.